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Welcome to Rational ClearQuest

ClearQuest is a customizable defect and change tracking system designed for
the dynamic environment of software development. With ClearQuest, you
can manage every type of change activity associated with software
development, including enhancement requests, defect reports, and
documentation modifications.

ClearQuest shortens development cycles by unifying your entire team in the
process of managing software change:

Development engineers can identify and prioritize action items that
pertain to their section of code.

Test engineers can track the status and resolution of change requests to
verify software quality.

Project leaders and managers can get information at a glance to help them
allocate development resources, streamline work flow, and accurately
determine release dates.

Administrators can integrate ClearQuest with existing tools and
customize it to fit your organization’s workflow.

This guide provides an overview of how to use ClearQuest on the job and a
brief example of how your ClearQuest administrator can customize
ClearQuest to fit your workflow. For instructions on how to install
ClearQuest, see the Installing Rational ClearQuest guide that came with your
product.



What is ClearQuest?

ClearQuest consists of several components that work in a client-server

environment.

Component Used by Use to

Client tools

ClearQuest Everyone Submit, modify, and track change requests, and to

for Windows analyze project progress by creating and updating
queries, charts, and reports.

ClearQuest Everyone Submit, modify, and track change requests, and

for UNIX support project analysis by creating and updating
queries.

ClearQuest Web Everyone Access ClearQuest geross multiple platforms through
Netscape Navigator— or Microsoft's Internet Explorer
to submit, modify, and track change requests, and
support project analysis by creating and updating
queries and reports.

Administrator tools

ClearQuest Designer ClearQuest Customize ClearQuest, manage ClearQuest schemas

administrator

and databases, and administer users and user
groups.

ClearQuest ClearQuest Import data including records, history, and

Import Tool administrator  attachments from other change request systems and
between ClearQuest databases.

ClearQuest ClearQuest Export ClearQuest data from one ClearQuest user

Export Tool administrator  database to another user database.

ClearQuest Everyone Set up and connect to the schema repository during

Maintenance Tool installation and when you upgrade to a new
ClearQuest version.

Rational E-mail Reader ClearQuest Enable ClearQuest users to submit and modify

administrator

records by e-mail.

For more information, see Chapter 9, “Administering
ClearQuest E-mail” in Administering Rational
ClearQuest.
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Ready-to-use defect tracking system

ClearQuest includes predefined schemas that provide ready-to-use change
and defect tracking processes and integration with various Rational Software
products. You can use ClearQuest schemas as is or customize them to fit your
organization’s workflow. For a list of ClearQuest predefined schemas, see
“Selecting a ClearQuest schema” on page 31.

Support for your development environment

ClearQuest provides the following support for your software development
environment:

Supports Microsoft Access® (included with ClearQuest), Sybase SQL
Anywhere (included with ClearQuest), Microsoft SQL Server®, Oracle
relational databases, and IBM DB2.

Integrates with Rational ClearCase and Microsoft Visual SourceSafe so
you can associate change requests directly with changes in your evolving
software.

Integrates with Rational TeamTest, VisualTest, Purify, PureCoverage, and
Quantify, allowing you to submit change requests to ClearQuest directly
from these testing tools.

Includes Seagate’s Crystal Reports Professional Edition™ so you can
create custom reports from ClearQuest data.

Allows you to integrate with other standard Windows tools, such as
Microsoft Excel and Word through an advanced COM interface.

Provides access to Rational Unified Process through the ClearQuest Help >
Rational Extended Help menu.

Supports Microsoft 1S web server.

What is ClearQuest? 3



Where to get more information

ClearQuest includes the following documentation:

ClearQuest Introduction
ClearQuest Help
ClearQuest Designer Tutorial

Administrators

ClearQuest Adminstrator's Guide ClearQuest Release Notes

ClearQuest APIl Reference ClearQuest Installation
ClearQuest Administrator's Guide
ClearQuest MultiSite Administrator's Guide
ClearQuest Multiutil Help
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On the job with ClearQuest

This chapter is for all ClearQuest users. It introduces the basic concepts of
using ClearQuest, including information on how to:

Submit a change request.
Work with change requests.
Track change requests.
Gather project metrics.

If you're reading this chapter as a ClearQuest administrator, look for the

] ClearQuest Designer icon next to suggestions for how you can customize
ClearQuest to fit your organization’s workflow.

For more information, read “Administering and customizing ClearQuest” on
page 17.

Note: The examples in this chapter show the Def ect Tr acki ng

schema and SAMPL database that are included with ClearQuest. This
represents only one model for using ClearQuest. For more information, see
“Selecting a ClearQuest schema” on page 31.



Getting started

Type your user
name and
password

Select a
database

To start using ClearQuest:
1 Select Rational ClearQuest from the Start menu.

2 Log into ClearQuest. You can use the ClearQuest predefined user name
(admin) to get started. You do not need to type a password.

Select the SAMPL database to experiment with a working user database that
already contains many change request records.

Rational ClearQuest Login HE

v

zer Mame Iadmin
Pazsward I
Databaze I SAMPL - j

(] I Cancel | Help ||

During installation, you create and configure user databases for your site;
their names appear in the drop-down list of databases when users log in. See
Installing Rational ClearQuest. You use ClearQuest Designer to set up user
login accounts and to define user access privileges. See Chapter 6,
“Administering users” in the Administering Rational ClearQuest guide.
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Getting around in ClearQuest

The ClearQuest main window consists of a Workspace, a Query Builder, and
a Record form.

The Query Builder displays the results of a query. Click a record
to display its data in the Record form below.

The Workspace
I- 1 th g Rational ClearQuest - [SAMPL :  [All Defects [Defect])]
. ISts e |:| File  Edit View Actions HQuery Window Help _|5 5‘
queries, charts, =N [l Bunbuey | ﬂ|b S|w2|  HewDerert v 2y & |ms @”
and reports that - id State Headline
are available =4y Workspace: Queriss, Charts| ([T 01 lOpened  speling sio an
([0 Personal Queries Resalved sales tax inco deleted from purchase
=] a Public Queries SAMPLOOODOODZ Resalved cancel sale dogsn't camectly repaint screen
(2 Aging Charts SAMPLODONO004 Resokved want more help on inventory report
. Customers SAMPLO0DD000S Resolved columng out of alighment
Double-click a Distritution Charts SAMPLONON0N0G Opensd delete iem ot working comectly
Email Rules SAMPLODO0O007 Resolved overide price does not work. '|
query to Fieport Formats [\Result set { Query edtar £ Display edtar /
locate records Reports
in the database % ;rgdfc"a"s Main | Motes| Resoution| Attachments| Histow|  Customer
efects
T Kepword Search D: [SAMPLODDO000T State: [Opened &I
% mj ?stDL:tL\Sl Headine:  [spelling errar in lagin screen Ea—
' T Needs Vefication Project IWI Kepwards: -
- Print
Usef the I;Qecprd Severity: 3fwerage - 4|
orm to view ’—I
and to modify Pricrity: 3-Homal Queue ~| Gpmptoms: Actians W
g
Dener. lead -
records
S ” h h Description:
croll throug =]
multiple records
from the same
query or type the
number of the L]
record you want
to locate — 8 R
»
Record 1 [Cowt 2

The Public Queries folder in the Workspace contains the queries, charts, and
reports that are included in ClearQuest, as well as any that your ClearQuest
administrator creates. You can drag any query, chart, or report to your
Personal Queries folder and modify it to suit your needs.

You can click Print to print a single record. To do this you must have a report
format associated with the record type. Look up Print Single Record in the
ClearQuest Designer Help index.

For more information, select Help > Contents > Getting around ClearQuest.
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Submitting a change request

You begin using ClearQuest by submitting a change request. This creates a
record in the user database that everyone on the team can track as your
software development and testing evolves.

To submit a change request, click = HewDefect | ¥ | in the toolbar.

Submit Defect SAMPLO0000045 = B3
Tabs with a red—-a Main | Qttachmentsl Qustomerl
square contain D: [5&MPLOGO00045 State:  |Submitted
mandatory fields
Headline: |
Cancel
Project I j Keywaords: J
Fields labeled in———=eveiits | = Load Defaul
=] eraul
red are
Pricity: I j e — Save as Default J
mandatory I
Dwner: I j
Description:
Save field values
as default and
load them the
next time you
submit a change |
request

Use the various tabs on the Submit Defect form to describe the change request
in detail, including attaching code fragments and other supporting
information. Some tabs contain fields that are mandatory. For example, the
Headline field requires a short sentence describing the problem, and you
must select a value for the Severity field.

You can save frequently used field values as defaults so you don’t have to
re-enter them each time you submit a change request. Fill in the fields you
want to save and select Values > Save as Default.

Note: You can submit a change request directly to ClearQuest from Rational
TeamTest, Purify, PureCoverage, Quantify, and Visual Test. You can also use
ClearQuest Web and ClearQuest UNIX to submit and modify change requests
or submit change requests via email.

As a ClearQuest administrator, you can create additional record types. For
Ll example, you might want separate record types for hardware defects,
software defects, and enhancement requests. You can also customize record
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forms, including adding tabs and fields and defining their behavior. See
Chapter 5, “Customizing a schema” in the Administering Rational ClearQuest
guide.

For more information, select Help > Contents > Working with records.

Receiving automatic e-mail notification

Your ClearQuest administrator can configure ClearQuest to automatically
send e-mail to various team members when a change request is submitted or
changed. To take advantage of automatic e-mail notification, all ClearQuest
users must set up their e-mail options. Select View > E-mail Options.

For more information, select Help > Contents > Using ClearQuest >
Setting up e-mail notification.

ClearQuest’s Email_rule record type makes it easy to define the rules for

1l sending automatic e-mail notification to ClearQuest users. The Email_rule
record type is part of the E-mail package included in every ClearQuest
out-of-the-box schema. You can also use the Rational E-mail Reader to
configure your e-mail settings so that ClearQuest users can submit and
modify records by e-mail.

For more information, in ClearQuest Designer, select Help > Contents > Using
e-mail features. Read Chapter 9, “Administering ClearQuest E-mail” in the
Administering Rational ClearQuest guide.

Submitting a change request 9



Working with change request records

You work with change request records by moving them through various
stages, or “states.” In each state, you can perform actions such as modifying
the record or moving it to another state. The Actions menu lists the actions

that you can perform on the record while it is in any given state.

Here’s an example of a typical workflow:

Assigning a change request

A change request record usually starts out in the Submitted state. The first
thing to do is to assign the change request to the engineer responsible for that

section of code.

The record is in the Submitted state

Main | ﬂotesl Besolutionl Qttachmentsl ﬂistoryl Qustomerl
D: [saMPLOO000Z] State: [Submited &l
Headline: Iinventory repart iz not running comectly Rewert |
. dst
Proiect  [ClassiesPOS o] =
I J Frint |
Severity: |1 -Critical j
_Select B I j Symptams:
Actions > [ Modify
Assign . Quiner: I ﬂ Azsign
Description: Cloze
. then fill in the =l pupleste
. . ‘0stpone
information on Deleltje
each tab
of the record
form I

L) I 4 IID: 00000021

The Assign action changes the state of the record to Assigned.

page 19.
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Ul Dbein and the actions available in each state, depends on the ClearQuest
schema you are using and any customizations you have made to it. See




Modifying a change request

Opening and

When you —
change the
record state to
Resolved, you
must fill in the
Resolution field

Not all actions change the state of a change request. You can select Actions >
Modify to change some information on a change request without actually
changing its state.

resolving a change request

If you're the engineer assigned to the change request, you begin work by
selecting Actions > Open. This changes the record’s state to Opened; now the
rest of the team can see that you’re working on the problem.

When you finish your work, select Actions > Resolve to change the record’s
state to Resolved.

Main|  Motes B Fiesoluion | Atachments|  Histoy | Customer

Apply

— Besolution: | |

Revert

Duplicate Information

Duplicate OF: Print

Duplicates:
Actions

Jekk

4|40 00000021 LA

In this example, the ClearQuest administrator has configured ClearQuest to
send an automatic e-mail notification to the Quality Assurance team as part of
the Resolve action. A quality assurance engineer can then verify that the
problem is fixed and change the record state to Closed.

As a ClearQuest administrator, you can restrict actions to specific user
groups. For example, you might allow everyone on the team to resolve a
change request, but restrict the Verify action to members of the Quality
Assurance group.

Working with change request records 11



Tracking change request records

ClearQuest queries make it easy for everyone on your team to track change
request records as they move through your system.

Using public queries

Double-click
Keyword
search and type
a keyword in the
Dynamic Filters
dialog

The Result set
tab displays the
records

for the query

ClearQuest includes ready-to-use queries that help you locate records by
project or component, by assigned engineer, by level of severity, and so on.
For example, when you discover a defect in your software, you can check to
see if the defect has already been submitted. Select Public Queries > All Defects
to display all the records in the database, or use the Keyword search query to
locate records containing a specific word in the Headline or Description field.

These records are the result of a keyword search
for records containing the word sale

B Rational ClearQuest - [SAMPL - [Keyword Search [Defect])]

[l Fle Edt Wiew Actions Quewm MWindow Help

_18 x|
=R £ Bty | &8 ‘@m’ | towvoient = | t] sgls] 3 |mi ]|
| ] id State Headline B
=63 Workspace: Queries. Chatts. || SAMPLOONNN00Z Resolve: sales lax incariect i item deleted fom purchase

(23 Personal Queries (| SAMPLODDD0003 Riesalver ‘cancel sale does correlly repaint screen
1Y Public Queries (| SAMPLODD0000S Riesalver invertory re-order not done on large sale
(] Aging Chatts Fiesolver logout buton should led duing sale
(] Custorers 0 Opened logout in middle of sl aborts sale
[#2] Distribution Charts sales kax incorect for NH
(23 Email les || SAMPLODDDD03T speling ermor in cancel sale help
(2 Report Farmats Result set £ Guery editor £ Display edfor
B Reports F —
% Trend Charts Main | Hotes| Resolution]  Atachments|  Histons]  Customer| m
i3 Al Defects
+-{T Kepnord Search D SAMPLOO0000T3 State: [Opened &I
g mz :;"DL:LSI Headine:  [logout in middie of sale abors salel o
T Needs Veriication L = Keywords 0
Piint
Severly  [BEvhancement =]
Priorty:  [3-Nomal Queue =] Sumpims:
J|
D engineer -
Description:
Ll 3 =l
Fecoid 5 Count 7

During a session of submitting new defects, you can select

Query > RecentlySubmitted to see a list of the defects you have submitted since
you logged in.
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Modifying queries

To modify a query, first drag the query to your Personal Queries folder and
then use the Query editor and Display editor tabs.

Drag a query to

B8 Rational ClearQuest - [SAMPL - [Keyword Search [Defect])] [_[o]x]
your Personal g Edt Yew ctions Quew window Hel NEET]
Queries folder il =| #]=[= El BunOwey | 8JE| [N | bewbotest |+ 20| o[m|=]|

before ﬁf‘ Fields Fiters |
e £ Workspace: Hueriss, Charts
modifying it (3 Personal Queies (3 Defect fl Bl ]
avarites ? : :
.3 Publc Queres = Favai 2 Headline : Headine Contains
03 A s o 0 Al 9 Desciption; Description Contains:
{2 Customers Attachments
(121 Distribution Charts customer
Select the (20 Email Fules customer_severiy hd
. (1 Report Fomats \ Resultset ) Query editor £ Display edilor /.
Query editor 1 Repots =
tab to change %;:IESSFE::S"S Main | pgles | Besn\uty/l ttachmerts | Histoy | Customer - B
the filtering £ Keyword Sestch SAMPLODDDORG2 State; [Fesobved il
criteria for % mi o - [veles tan forrect ¥ e deeted from purchase o
----- £ Meeds Verfication — Keywords:
aquery L Piint
Severity:
Select the .y
Display editor Qumer: [ead - -
tab to set up Fecniy
C
how the query
results are
displayed
[2] |
4 » J

Fecard. 1 Count, 10 i

Building a new query

To build a new query from scratch or from an existing query, select Query >
New Query. The ClearQuest Query Wizard steps you through the process of
building a query.

For more information, select Help > Contents > Working with queries.

As a ClearQuest administrator, you can save queries to the Public Queries
folder and can assign this privilege to other users.

See Chapter 6, “Administering users” in the Administering Rational ClearQuest
guide.

Tracking change request records 13



Gathering project metrics

ClearQuest provides predefined charts and reports that you can run on
Windows and on ClearQuest Web to view the status of your project at a
glance. On Windows, you can modify these charts and reports to fit your own
needs. ClearQuest UNIX does not support the creation of charts or reports.

Using ClearQuest charts

Drag a chart to
your Personal
Queries folder

before
modifying it

Double-click
a chart to
display it

Right-click and
select Drill
Down from the
Shortcut menu
to show more
detail

ClearQuest charts display record data graphically. Distribution charts show
the current status of data; trend and aging charts show historical information.

For example, you can see how the workload is distributed among the
engineers on your team by running a distribution chart that displays the
defects assigned to each engineer. Or, you can see the defect records graphed
by state and severity.

Chart data is also displayed in tabular form

B, Rational Clear@uest - SAMPL : - [SAMPL : (Severity = [Defect))]

lul File Edt View Chat Actions Query Window Help =R
|| AEe| [E [ ance | GEH| S| newpeeot | | =] 2[4 855
s State
E-£3 Workspace: Queries, Chars| ([ Fesolved 1-Critical
(1 Petsonal Queries 2 Submitted 1-Ciitical
EE3 Public Queries 1 Opened Maion
{17 Aging Charts 2 Resolved Major
(2 Customers 4 Submitted M ajor
E=-E3 Distribution Charts |3 Opened Hivesge |
{2 Defsct by Prioritr [4] »
(] Delects By Dwn [\Result set £ Query edtor /.
£+ Defects by State
ul. Priorit .
ﬁ Seveﬁw Defects by State and Severity
|yl Active Defects £
{ul Active Defects £
~{ul Active Defects £
{ul Al Defects by O
|l &1 Defects by 5
ul Defect Count by O 1-Critical
-1 Email Rules o B 2Major
-] Report Formats E 3Aversge
(21 Repots Arnotate  Clied, —
e FrandEiar Diil Down  ClikD [ T e —
{TH All Defects Grid kG
{TH Keyword Search Copy CHkC
-EE My Hot List
T My To DoList Properties...
- Meeds Verification Resolved Submi zoom Oz
Stat  Rotate ChT
Move Chlehd
4 3 Scale Cirl+L
Feady Resst AlR e R T

There are two ways to modify the contents of a chart: Select
Edit > Properties to define how the data is displayed, or use the Query editor
tab to filter the records included in the chart.
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Creating reports from ClearQuest data

Choaoze a report farmat:
(22 Trend Charts =]
([ Aging Charts
([ Reparts
SeIeCt a =5 Report Famats
report ~[B Defect Detail
Defect Notes
format — - ect Summary!
[ Email Aules
[ Custamers -
Create Feport with
’7 © Selected Flows @ Al Fows
Ok I Lancel I Help I

ClearQuest
displays

the data in the
report format you
selected

ClearQuest includes reports and report formats that you can use to create
reports from ClearQuest data. To create a report on the current query results

set, first run a query such as All Defects, then click |i | to open the Create
Report dialog.

This creates a report in the selected format from the data in the query result

set. Click | g% | to export the report output to another format, such as HTML
or Excel.

B, Rational ClearQuest - [SAMPL - (Runtime Report (Defect])]

Fle Edt View Actons Query Window Help =lEx]
] o L= T = e - e et e i

Tof1+

0| » || Bl& 5 =

Totak40 100% 40 of 40

Defect Sumary

SAMPLADO0004 wnatmm bl mmsuny mpnt

Stuts  Turohud samcty  SEdbeneat srarty

SAMPLADO00S
Stite  Tarohud

Ready Record, 1 Coun, 7
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To create a new report that you can reuse, run a query that you want to create
a report from, and then select Query > New Report.

Choose Record Type. . . EHE

Fleaze choose a record type
fram the following list:

Define Report [ 7] %]
Select a report Repart Format:

format IF'uinc: Queries'Report FormatshDefec Erowse... |
Query to Apply:
Select a —IF'uinc: Queries\all Defects
query
QK | Cancel | Help |

Select a report format and then associate the format with a query.

This creates a report from the query data you selected. You can save this
report in your Personal Queries folder and run it at any time.

You can use Crystal Reports Professional Edition to create new report
formats. You can save these formats in your Personal Queries folder and use
them to format ClearQuest reports.

For more information, see Help > Contents > Working with reports.

Now you’re ready to put ClearQuest to work. Remember that ClearQuest
Help contains detailed information to assist you every step of the way. For
context-sensitive Help, click |E| and then click the item you want
information about.

%ﬁ Be sure to read the next chapter, “Administering and customizing
el ClearQuest.”
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Administering and customizing
ClearQuest

This chapter is for ClearQuest administrators. It begins with an overview of
ClearQuest databases and schemas, then provides a brief example of how to
perform the primary task of an administrator—customizing a ClearQuest
schema to fit your workflow.

Note: For complete information about administering ClearQuest, including a
description of how to get your ClearQuest users up and running, see the
Administering Rational ClearQuest guide that came with your ClearQuest
product. To take the tutorial, select ClearQuest Designer Tutorial from the Start
menu.

Overview of ClearQuest databases and schemas

A ClearQuest schema contains the metadata that defines the process for how
users work with records in ClearQuest.
It includes:

Record type definitions.

Forms used to submit and modify a record.

Field definitions and behavior.

States a record can be in.

Actions used to modify or change the state of a record.

Hooks written in Visual Basic Script™ or Perl that further customize fields
and actions.

Note: ClearQuest includes several predefined schemas that you can use as is
or customize to fit your workflow. For a list of these schemas, see “Selecting a
ClearQuest schema” on page 31.

ClearQuest stores schemas in a schema repository. A ClearQuest installation
usually consists of one schema repository and one or more user databases.
You can have separate user databases for each project, or group several
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projects together into one database. If you want to generate reports and charts
across several projects, you should put the projects in the same database.
Projects that share a database must use the same schema.

Here’s an example of how a schema repository with two schemas can work
with several user databases:

Schema Repository

You can upgrade these Def ect Tr acki ng schema
databases with newer Database for project X I rev1
versions of the

rev 2
Def ect Tr acki ng 7 '
schema Database for project Y / .

rev 25

Database for project Z

. nmyschema schema
You can upgrade this

. revl
database with newer
versions of the
nyschema schema_’ Test database I .
rev 10

Note: Once a database is associated with a schema, it can only be upgraded
with a newer version of that same schema. It cannot use an older version of the
schema or a completely different schema.

In the above example, you can:

= Upgrade the databases for projects X, Y, or Z with newer versions of the
Def ect Tr acki ng schema.

= Upgrade the Test database with newer versions of nyschema.

= Apply any version of the Def ect Tr acki ng schema or the
nyschema schema to a new database.

For a complete description of how to work with schemas and databases, see
Chapter 4, “Working with ClearQuest schemas” in the Administering Rational
ClearQuest guide.
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Starting ClearQuest Designer

To start ClearQuest Designer:

1 Select Rational ClearQuest Designer from the Start menu.

Click to check out a

ClearQuest provides a default User Name (admin) that you can use to get
started. Do not type in a password. The admin user account is set up with

the access privileges you need to perform all ClearQuest administrator

functions. To change the admin account, select Tools > User Administration,
then select the admin user and click Edit.

For more information on user-access privileges, see Chapter 6,

“Administering users” in the Administering Rational ClearQuest guide.

ClearQuest Designer displays the Open Schema dialog.

Check out a schema if you are planning to modify it and click Finish;

otherwise click Cancel to continue.

schema

Select a schema

Click if you are
checking out a
schema

Click if you are not
checking out a
schema

= Checkout a echema bo edit or

continue editing previously zaved wark.

™ iew a version of an existing schema.

Schema Latest | Checked| Checke «
Mame Version|  Out Owr
3 |DefectTracking 1 Ma
4 | AnalvstStudio 1 Ma
5 | DevelopmentStudio 1 Ma e
E | TestStudio 1 Mo
7 | UnifiedChanget anagement| 2 ez admin -
[al C i bmrmriee 1 kl-
A1 _>|_I
¥ Show this wizard at startup
¢ Bachk I Firish I Cancel | Help

Starting ClearQuest Designer
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Customizing a schema

When the record
is in the
Submitted

state . . .

...youcan
modify or
resolve the
defect

This section provides a brief example of how to customize a schema. Suppose
you have a simple defect record with only two states (Submitted and Closed)
and three actions (Submit, Modify, and Resolve). The process of working with
this record is shown in the state model below:

Resolve

= State

— » =Action

The defect record begins in the Submitted state; from there you can select
Actions > Resolve to change the record state to Closed, or Actions > Modify to
modify the record without changing its state.

The record form looks like this:

Surnmiary | Motes I

el |

id Itut‘l 0000000 State [Submitted
Eievert |

headline IEopyright date incomect in about box.

Frint |

description

Change copyright date in about box to 2000,
adify

Resolve

submitted_by aszigned_to

IDE j Iengineer j
submitted_date

|5.-’1 /00 12:00:00 P _

4]0 00000001 3 I DII

The process of working with a record, along with the record form and fields,
is defined by the ClearQuest schema.
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In this example, you modify the process of working with the defect record by
adding an Opened state so that the state model looks like this:

Resolve

O = State

— » = Action
To customize the schema to fit this new workflow, you will;
Add a new state, Opened, between the Submitted and Closed states.

Add a new action, Open, that changes the state of the record from
Submitted to Opened.

Add a field, planned_fix_date, to the record form.
Define the behavior of the planned_fix_date field.

Create a Visual Basic hook that automatically sets the planned_fix_date field
equal to three days from today’s date.
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Checking out the schema

To customize a schema, you must first check it out of the schema repository.
Select File > Open Schema. For complete instructions on working with
schemas, including setting up a test database to test your schema
customizations, see Chapter 4, “Working with schemas,” in the Administering
Rational ClearQuest guide.

Adding a new state

Double-click to
open the State
Transition Matrix

Click Edit > Add
State and type
Opened

The ClearQuest Designer State Transition Matrix shows the various states
that a record can be in and the actions that move the record from one state to
another. In this example, it shows that the Resolve action changes the record
from the Submitted state to the Closed state.

To add a new state, open the State Transition Matrix and then select Edit > Add
State.

%9, Rational ClearQuest Designer - [Defect: State Transition M atrix]
] File Edit “iew Database Tools Package ‘Window Help

=181 x]

D] oole| @B v|ola] s =elE] o] e
Tylrom Submitted
Subrmitted
Clozed

E-E3 TutorialSchema, version 3 Clozed -

=& Record Types
1423 Defect
- E3 Fields
E1429 States and Actions

Resolve

— [ State Transition Matrix
4@ Actions
4o Behaviors

Add State K E

Mame: IUDENEC'

QK I Eancell Help |
o

|Mode: Editable 4

-] Forms

-] Record Scripts
[#-(_] Record Types - Stateless
([ Record Type Famiies
-7 Global Scripts

----- [ Dynamic List Mames | 1 ! I
4

|Line:  Col:

Feady

For more information, look up states, creating in the ClearQuest Designer Help
index.
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Adding a new action

The Actions grid shows all of the actions that can be performed on a record.
To add a new action, you first add the action to the Actions grid and then
associate it with the appropriate states.

%ﬂ Rational ClearQuest Designer - [Defect: Actions]

] File Edit Wiew Database Tools Package ‘Window Help _Iﬂlil
C e ol ml@| v|al8] fl=leE] 2] x|
=455 Tutorials chema, verzion 3 Action Mame Type Access Control| Initialization| |
[ Schema Properties Submit SUBMIT All Users
E1-23 Record Types Import IMFORT All Users
E‘a Diefect badify MODIFY All Uszers
H 2= Resolve CHAMGE_STATE All Uzers
- —-EA Field !
1. Double CI'(_:k to =B Stots and A ¥ | Gpen CHANGE STATE S &l Users
open the Actions sies andacions - Add Ac
i 8 State Trarsition Matix (e E
grid @ Actions Delete Action
i i-{tp Behaviors Bename Action. .
2. In the Action -2 Ferms e
Name column, (-2 Record Scripts
[#-[_7] Record Types - Stateless ‘what's This 7
type Open ] Fecard Tppe Families I
[#-[1] Global Scripts
3. In the Type (23 Dynamic List Mames d
column, select . | n
CHANGE STATE___Editthe propery of the selected object |Li 3 Caol: |M0de: Editable G

5. In the State tab,
select Submitted
for the

source state. .. ——  Source States
...and Opened
for the —_
. . Drestination Opened -
destination state —- State: [op |

4. Right-click the Open action
and select Action Properties
from the shortcut menu

ﬂlil Thiz dialog box containg properties of the selected action.
To get more information, select

) o
General  State I Help Textl What's This?

This adds the Open action to the ClearQuest Actions menu. Now, when the
record is in the source state (Submitted), you can select Actions > Open to
move the record to the destination state (Opened).

You should also modify the existing Resolve action to add Opened as a legal
source state.
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Look at the State Transition Matrix again. It now shows that the Open action
moves the record from the Submitted state to the Opened state, as intended.

;iﬁ Rational CleaiQuest Designer - [Defect: State Transition Matrix]

] File Edt Yiew Database Tools Package ‘window Help _Iﬁllll
D] eole| @R v| (@] k(]| ] el
EHE9 Tutorial3chema, version 3 Falrem Submitted Closed Opened [«]
D Schema Properties Submitted
£ Record Types Closed  |Resolve Resolve
Double-click to £ Defect |[@rered | Open
; Fields

open the State
Transition Matrix

4] States and Actions

& State Transition Matriz
4@ pctions

-7 Behaviors

-2 Farms

®-([7] Record Scripts
The new Open [+ Record Tupes - Stateless

action moves the (3 Record Type Fanilies
record from (1] Global Scripts
Submitted to -[Z7] Dynamic List Names

Opened 4 | _'ILI

FReady |Line:  Col |Mode: Editable 4

You can see how the State Transition Matrix implements the new state model.

Resolve

Resolve

= State

— = =Action

In the Submitted state, you can select Actions > Open to change the state to
Opened. In both the Submitted state and the Opened state, you can select
Actions > Resolve to change the record to Closed.

For more information, look up state transitions in the ClearQuest Designer
Help index.
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Creating a new field

Double-click to
open the
Fields grid

Now, create a new field for the record form called planned_fix_date that lets
you enter the date when you expect to resolve the defect.

To create a new field, open the Fields grid. The Fields grid shows all of the
fields on the record form, their type, and their default values.

Type
planned_fix_date
in the Field Name
column

Click the Type
column and
select Date_Time
as the field type

?m Rational ClearQuest Designer - [Defect: Fields]
= File Edit Yiew Database Tools Package “Window Help - E‘|5|
Dl eola| B[] | 18| - ||e|s] 8] ]
=23 TutorialSchema, version 3 Field Mame Type Default Value| Permission | Value Changsdl;
[[] Schema Properties f:lbid ] DEID
-4 Record Types !sfacllve IMT
=143 Defest d ]
e State STATE
=29 States and Actions HEEN INT
H lock_wersion IMT
- State Transition Matrix
® Actions locked by INT
o o Fistery JOOANAL
{2 Behaviors is_duplicate THT
(] Foms . unduplicate_state SHORT_STRING
(3 Record Sciipts record_type RECORDTTPE
B+ Record Types - Stateless headine SHORT_STRIMG
-+ Record Type Families description MULTILINE_STRING
B~ Global Seripts submitted_by REFERENCE
«+[27] Dynamic List Names assigned_to REFEREMNCE
submitted_date DATE TIME
# | planned_fix_date DATE_TIME 2
SHORT_STRING
MULTILINE_STRING|
INT
REFERENCE
REFERENCE_LIST ]
ATTACHMENT LIST
-
4 | »
Fieady [Line: ~ Cak: [Mode: Editable v

For more information, look up fields, adding to schemas in the ClearQuest
Designer Help index.
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Defining the behavior of the new field

The Behaviors grid shows how fields behave when the record is in each state.
You can define whether a field is read-only, mandatory, or optional in each
state, or define default behavior for all states. You can also create a use-hook
behavior that restricts user access to the field. For more information, refer to
the ClearQuest API Reference.

Open the Behaviors grid, then right-click and use the popup menu to define
the behavior of the planned_fix_date field.

You can define the behavior of the field in each state

?m Rational ClearQuest Designer - [Defect: Behaviors]

1 Fle Edt ‘iew Datsbase Tools Package Window Help _|E'|5|
L] || @8] v|o|8] s[mle|-] 2] x|
=25 Tutorials chema, version 3 Submitted Closed Opened Default Behaviar
+--[ Schema Properties dhid READOMLY  |READONLY  |READOMLY  [READONLY
E1E3 Record Types is_active FEADONLY |READOMLY |READOMLY  |READOHLT
=-{3 Defent id FEADOMLY |READONLY |READOMLY  |READONLY
Double-click to B Fields State FEADOMLY |READONLY |READOMLY  |READONLY
uble-cli 28 Statgs a"dTACtP”S W version AEADONLY |READONLY |READDNLY  |READONLY
open the ::g State Transion Mtk | | ISohveisin | FEADUNLY |FEADONLY |FEADUNLY _[READONLY
Behaviors grid 2 Behaviers locked_by FEADONLY |READONLY |READOMLY  |READONLY
B1-(Z3 Foms histary FEADONLY |READONLY |READOMLY  |READOMLY
E1-(33 Record Soripts is_duplicate: FEADONLY |READONLY |READOMLY  |READONLY
B+ Record Types - Stateless UndupliEstenstaie| FEADOMLY  [READOMLY  [READOMLY — [READONLY
(23 Record Type Families record_type FEADONLY |READONLY |READOWLY  |READONLY
The regord form -] Global Seripte headine MANDATORY [OPTIONAL  |OPTIONAL  |OPTIONAL
contains these (3 Dynanic List Names Tl MANDATORY |OFTIONAL  |OFTIONAL  |OPTIONAL
fields submitted_by | MANDATORY [OPTIOMAL  |OPTIONAL OPTIOMAL
assigned_to OFTIONAL  |OPTIONAL  |OFTIONAL  |OFTIONAL
submitted_date | MENDATORY [OFTIOMAL  |OFTIONAL  |OFTIOMAL
plarned_fix_date [OFTIONAL BeadOnp  |FTIOMAL  |OPTIONAL
Right-CliCk to Mandatary
define the EZQ?SLk
behavior of the ———— T
planned le date Set the field behavior to "M andatary' |Line Cal ‘Mnde Editable 4

field in each state

For more information, look up fields, behaviors in the ClearQuest Designer
Help index.
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Adding the new field to the record form

1. Double-click
to open

the Defect
record form

4. Use the
Property Sheet
to change the
text box
properties

5. When you
finish, close the
form window

After creating a field, you must add it to the record form. To add the
planned_fix_date field to the record form, open the Defect form. In the
Workspace, select Record Types > Defect > Forms > Defect.

Bij Rational ClearQuest Designer - Defect

Use the Controls Palette to add controls such as

check boxes and option buttons to a form

[_[o]x]

File Edt Yiew Database Iools Package Fomnlapout FormContiols Window Help
L =] eolo] @i v |5 &[] 2] e
el == @l
=424 TutarialSchema, version 3 W Defect
--[5 Schema Properties | |
=49 Record Types Summary | Motes
=9 Defect Arpl
— — £ [Fielde 4 ‘ ‘ | ‘
+)-(] States and Actions i State FEvET
| TUEE Defect headine |
(2 Feecord Scipts ﬂl
(2] Record Types - Stateless desciiption
(1 Record Type Families
-] Global Scripts
(] Dynamic List Names
h assigned_to
[ description
O head
submitted]_by assigned_to ; hz,amf'e
| gl [ = Ow
O s_duplicate
submitted_date planned_fix_date < =7 planned_fis_date
= record_type
9/23/39 933,00 AM =] 4 ot E L State
Copy : submited_by
Beste: [ submited_date
Properties
Ready [ine: Cal Mode: Edie
Tent Box Property Sheet .
2. Drag the planned_fix_date
General| Extended Date/Time | Conest Meru Hocks | ] - 7=
field onto the form
¥ Date ¥ Time
Dats Formats Tirne: Formats . .
2 3. Right-click the text box and select
[conticl panel - long date i
contielpanel-long date Properties from the popup menu
ok | caneel | e | Hep |

For more information, look up controls, adding to forms in the ClearQuest
Designer Help index.
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Creating an action hook

Hooks are triggers for pieces of code that ClearQuest executes at specified
times to more fully implement your workflow. ClearQuest provides many
predefined hooks that you can easily modify to suit your needs.You can also
use the ClearQuest application programming interface (API) to write hook
code in Microsoft VBScript or Perl.

ClearQuest supports four types of hook code:

= Field hooks provide a way to validate the contents of a field or to assign
field values.

= Action hooks implement tasks at key points in the life cycle of a record.

= Record scripts allow you to associate a hook with a control, such as a
push-button or shortcut menu option, on a single record.

= Global scripts allow you to reuse hook code in other hooks.

In this example, you modify the predefined ACTION_INITIALIZATION hook
for the Open action so that it initializes the value of the planned_fix_date

field.
a;ﬁ Rational ClearQuest Designer - [Defect: Actions]
| File Edt ‘iew Database Tools Package Window Help == x|
U] eole| @[@] v[sl8] & =|e(w] 2] x|
-3 TutorialSchema, version 3 Action Mame Type Access Control]  Initizlization Walidation ~ |
"-[3 Schema Fropertes Submit SUBMIT All Users
Al -5 Record Types Import IMPORT All Users
Double-click E’ Defect Moy MODIFY Al sers
Actions 7 Ficlds Resolve CHANGE_STATE All Users
to open the £ States and Actions ¥ | Open CHANGE_STATE Al Users |
. . [l State Transitior
Actions grid <& [Bctions NONE PERL
G2 Behaviors
. B[] Forms
Click the -] Record Scripts
Initialization (7] Recard Types - Stateless
-] Record Type Families
Column_ for the (1] Global Scripts
Open action and {1 Dynamic List Mames -
select e
. . 4] [ ONE | Ll_l
Scripts > Basic
Select/unselect Basic language for this cript |Line:  Col |Mode: Editable A

This opens the ClearQuest Script Editor.
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Add these lines
to the script

Checking in

Use the ClearQuest Script Editor to edit the ACTION_INITIALIZATION hook
so that it initializes the value of the planned_fix_date field to the current date
+ three days.

%\] Rational Clearuest Designer - [Dpen: Action Basic Scrpt Editor]

=] File Edit “iew Datshase Toolz Hooks Package Window Help _Iﬁllﬂ
D|D“‘| DD|4] |H v §}|§| %||E | Q| h2
=129 TutorialSchema, version 3 Hook Types: [ACTION_INITIALIZATION |
D Schema Propeities Sub defect TInitiaslizationiactionname, acciontype) ;l
Ea Record Types ! actionname Ls Jtring
El'a fe?’ ' actiontype As Long
Fields . ' action is Open
Ea States and Actions ! record type nawe is Defect
: BB State Transition

REN do any setup for the action here
[three_days = Now + 3

-4 Actions

~{e—Ereraion

DF [_=all SetFieldValue ("planned fix date", three days]l
o - - -

End Zub
-] Record Scripts
#-(_7] Record Types - Stateless
-(_7] Record Type Families
(0] Global Seripts
--+(Z7] Dynamic List Mames
1 DN Ll_l

Ready |Line & Col 52 |Mode: Editable s

For more information, look up hooks, overview in the ClearQuest Designer
Help index. Read Chapter 7, “Using hooks to customize your workflow,” in
the Administering Rational ClearQuest guide.

the schema

At any time while working on a schema, you can select File > Test Work to test
your work in progress. This upgrades the test database with your latest
changes, providing a quick way to test your changes in the ClearQuest client
without affecting your production user database.

When you're satisfied that your schema changes are working correctly, select
File > Check in to check the schema into the schema repository. Once the
schema is checked in, you can use it to upgrade your user database. Select
Database > Upgrade Database. ClearQuest prompts you to back up the schema
repository and the database before upgrading.

For more information, read Chapter 4, “Working with schemas,” in the
Administering Rational ClearQuest guide.
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Working with the new record form

When the record
is in the
Submitted

state . . .

.. click Open
to change the
record state to

Opened

The record state
changes to
Opened

The
planned_fix_date
field is filled in
automatically

After upgrading the user database with the customized schema, the defect
record form works like this:

|
|
’7

Open

|- ocoonoon[» [

The Open action changes the state of the record to Opened and automatically
fills in the planned_fix_date field.

Change copyright date in about box to 2000,

R

o sz r

|
el«jo ooosoonn o]
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Selecting a ClearQuest schema

Below is a list of the predefined schemas that are included in ClearQuest.
ClearQuest schemas consist of various packages that provide specific
functionality. You can add individual packages to an existing ClearQuest
schema or to your own customized schema. For complete descriptions of
ClearQuest schemas and packages, see your Administering Rational ClearQuest

guide.
Schema Description
AnalystStudio Compatible with Rational Suite Analyst Studio. Contains
customization for use with Rational RequisitePro.
Blank Contains only system fields. Use this schema to create a
schema from scratch.
Common Contains metadata that is common to all of the ClearQuest
schemas.
DefectTracking Contains the fields necessary to start using ClearQuest to

track defects in a software-development environment.

DevelopmentStudio

Compatible with Rational Suite DevelopmentStudio. Contains
fields and rules that work with Rational Purify, Quantify, and
PureCoverage.

Enterprise

For use with Rational Suite EnterpriseStudio. Contains fields
and hooks that work with all Rational products.

TestStudio

Compatible with Rational Suite TestStudio. Contains fields and
rules that work with Rational TeamTest, RequisitePro, Purify,
Quantify, and PureCoverage.

UnifiedChangeManagement

Supports the UCM process by providing integration with
Rational ClearCase.

Now, you’re ready to begin using ClearQuest Designer. Remember that
ClearQuest Designer Help contains detailed information to assist you every
step of the way. For context-sensitive Help, click |E| and then click the item
you want information about.
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